Issues on warning lights

#1
All 3 ACD LEDs light up at the same time upon startup. But will go off after the second startup.

Next issue, while driving, realised that the handbrake and battery light kept blinking and will also go off after a while.

Anyone experienced this before?
Any advise on what should be done?

Thanks
 
#2
elgtsakura said:
All 3 ACD LEDs light up at the same time upon startup. But will go off after the second startup.

Next issue, while driving, realised that the handbrake and battery light kept blinking and will also go off after a while.

Anyone experienced this before?
Any advise on what should be done?

Thanks
Could be a weak battery
 
#3
elgtsakura said:
All 3 ACD LEDs light up at the same time upon startup. But will go off after the second startup.

Next issue, while driving, realised that the handbrake and battery light kept blinking and will also go off after a while.

Anyone experienced this before?
Any advise on what should be done?

Thanks
Too many mods.. hee hee!

When kopi... ???
 
#4
dvp said:
elgtsakura said:
All 3 ACD LEDs light up at the same time upon startup. But will go off after the second startup.

Next issue, while driving, realised that the handbrake and battery light kept blinking and will also go off after a while.

Anyone experienced this before?
Any advise on what should be done?

Thanks
Could be a weak battery
Thanks bro for the reply. However the Apexi TT states batt at ard 13.6V.
Nevertheless, I will get the batt checked this weekend.

Cheers!
 
#5
DaDude said:
elgtsakura said:
All 3 ACD LEDs light up at the same time upon startup. But will go off after the second startup.

Next issue, while driving, realised that the handbrake and battery light kept blinking and will also go off after a while.

Anyone experienced this before?
Any advise on what should be done?

Thanks
Too many mods.. hee hee!

When kopi... ???[/quote



Posted: Thu Dec 01, 2011 5:23 pm     Post subject: Re: Issues on warning lights
Too many mods.. hee hee!

When kopi... ???
Dun think so unless it's the electrical connection.
Kopi anytime bro juz give me a ring :)
 
#6
elgtsakura said:
All 3 ACD LEDs light up at the same time upon startup. But will go off after the Tsecond startup.

Next issue, while driving, realised that the handbrake and battery light kept blinking and will also go off after a while.

Anyone experienced this before?
Any advise on what should be done?

Thanks
Bro you still have this problem? I when thru a lot of pain recently to solve this problem. Finally got raid of the issued I can share my experience if you need help. Message me at 91267336.
 
#7
bk_knight said:
elgtsakura said:
All 3 ACD LEDs light up at the same time upon startup. But will go off after the Tsecond startup.

Next issue, while driving, realised that the handbrake and battery light kept blinking and will also go off after a while.

Anyone experienced this before?
Any advise on what should be done?

Thanks
Bro you still have this problem? I when thru a lot of pain recently to solve this problem. Finally got raid of the issued I can share my experience if you need help. Message me at 91267336.
Thks bro for the efforts.I have solved the issues.

Appreciate your eagerness to assist me to solve these issues.
For the benefit of our fellow bros

Below are the causes
1) low differential oil limit warning : the oil tank located in the boot (causing the occasional light up of all the ACD LEDS)
2) Weak Alternator or weak Battery basically weak charging warning (Handbrake light and battery light occasional blinking while driving)

Cheers!
 

Similar threads


Top